blob: 7bfc8eece4272eb426511356a9419c720b248b22 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001require grub2.inc
2
3GRUBPLATFORM = "efi"
4
5DEPENDS_append_class-target = " grub-efi-native"
Brad Bishop316dfdd2018-06-25 12:45:53 -04006RDEPENDS_${PN}_class-target = "diffutils freetype grub-common virtual/grub-bootconf"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05007
8SRC_URI += " \
9 file://cfg \
10 "
11
12S = "${WORKDIR}/grub-${PV}"
13
14# Determine the target arch for the grub modules
15python __anonymous () {
16 import re
17 target = d.getVar('TARGET_ARCH')
Brad Bishop316dfdd2018-06-25 12:45:53 -040018 prefix = "" if d.getVar('EFI_PROVIDER') == "grub-efi" else "grub-efi-"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019 if target == "x86_64":
20 grubtarget = 'x86_64'
Brad Bishop316dfdd2018-06-25 12:45:53 -040021 grubimage = prefix + "bootx64.efi"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050022 elif re.match('i.86', target):
23 grubtarget = 'i386'
Brad Bishop316dfdd2018-06-25 12:45:53 -040024 grubimage = prefix + "bootia32.efi"
25 elif re.match('aarch64', target):
26 grubtarget = 'arm64'
27 grubimage = prefix + "bootaa64.efi"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050028 else:
Brad Bishop316dfdd2018-06-25 12:45:53 -040029 raise bb.parse.SkipRecipe("grub-efi is incompatible with target %s" % target)
Brad Bishopd7bf8c12018-02-25 22:55:05 -050030 d.setVar("GRUB_TARGET", grubtarget)
31 d.setVar("GRUB_IMAGE", grubimage)
Brad Bishop316dfdd2018-06-25 12:45:53 -040032 prefix = "grub-efi-" if prefix == "" else ""
33 d.setVar("GRUB_IMAGE_PREFIX", prefix)
Brad Bishopd7bf8c12018-02-25 22:55:05 -050034}
35
36inherit deploy
37
38CACHED_CONFIGUREVARS += "ac_cv_path_HELP2MAN="
39EXTRA_OECONF += "--enable-efiemu=no"
40
41# ldm.c:114:7: error: trampoline generated for nested function 'hook' [-Werror=trampolines]
42# and many other places in the grub code when compiled with some native gcc compilers (specifically, gentoo)
43CFLAGS_append_class-native = " -Wno-error=trampolines"
44
Brad Bishop316dfdd2018-06-25 12:45:53 -040045do_mkimage() {
46 cd ${B}
47 # Search for the grub.cfg on the local boot media by using the
48 # built in cfg file provided via this recipe
49 grub-mkimage -c ../cfg -p /EFI/BOOT -d ./grub-core/ \
50 -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} \
51 ${GRUB_BUILDIN}
52}
53
54addtask mkimage before do_install after do_compile
55
56do_mkimage_class-native() {
57 :
58}
59
60do_install_append_class-target() {
61 install -d ${D}/boot
62 install -d ${D}/boot/EFI
63 install -d ${D}/boot/EFI/BOOT
64 install -m 644 ${B}/${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} ${D}/boot/EFI/BOOT/${GRUB_IMAGE}
65}
66
Brad Bishopd7bf8c12018-02-25 22:55:05 -050067do_install_class-native() {
68 install -d ${D}${bindir}
69 install -m 755 grub-mkimage ${D}${bindir}
70}
71
Brad Bishop316dfdd2018-06-25 12:45:53 -040072do_install_class-target() {
73 oe_runmake 'DESTDIR=${D}' -C grub-core install
74
Brad Bishopd7bf8c12018-02-25 22:55:05 -050075 # Remove build host references...
76 find "${D}" -name modinfo.sh -type f -exec \
77 sed -i \
78 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
79 -e 's|${DEBUG_PREFIX_MAP}||g' \
80 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
81 {} +
82}
83
84GRUB_BUILDIN ?= "boot linux ext2 fat serial part_msdos part_gpt normal \
Brad Bishop316dfdd2018-06-25 12:45:53 -040085 efi_gop iso9660 configfile search loadenv test"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050086
87do_deploy() {
Brad Bishop316dfdd2018-06-25 12:45:53 -040088 install -m 644 ${B}/${GRUB_IMAGE_PREFIX}${GRUB_IMAGE} ${DEPLOYDIR}
Brad Bishopd7bf8c12018-02-25 22:55:05 -050089}
90
91do_deploy_class-native() {
92 :
93}
94
95addtask deploy after do_install before do_build
96
Brad Bishop316dfdd2018-06-25 12:45:53 -040097FILES_${PN} = "${libdir}/grub/${GRUB_TARGET}-efi \
98 ${datadir}/grub \
99 /boot/EFI/BOOT/${GRUB_IMAGE} \
100 "
101
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500102
103# 64-bit binaries are expected for the bootloader with an x32 userland
104INSANE_SKIP_${PN}_append_linux-gnux32 = " arch"
105INSANE_SKIP_${PN}-dbg_append_linux-gnux32 = " arch"
106INSANE_SKIP_${PN}_append_linux-muslx32 = " arch"
107INSANE_SKIP_${PN}-dbg_append_linux-muslx32 = " arch"
108
109BBCLASSEXTEND = "native"