blob: c814798bbd12e9584a652ca36917c2d72e0decf6 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001require glibc.inc
2
3LIC_FILES_CHKSUM = "file://LICENSES;md5=e9a558e243b36d3209f380deb394b213 \
4 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
5 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
6 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
7
8DEPENDS += "gperf-native bison-native"
9
10SRCREV ?= "df3ff4e49d4ee3cbbdaeb0b1cb5dc2344c08be98"
11
12SRCBRANCH ?= "release/${PV}/master"
13
14GLIBC_GIT_URI ?= "git://sourceware.org/git/glibc.git"
15UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+\.\d+(\.(?!90)\d+)*)"
16
17SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
18 file://etc/ld.so.conf \
19 file://generate-supported.mk \
20 \
21 ${NATIVESDKFIXES} \
22 file://0005-fsl-e500-e5500-e6500-603e-fsqrt-implementation.patch \
23 file://0006-readlib-Add-OECORE_KNOWN_INTERPRETER_NAMES-to-known-.patch \
24 file://0007-ppc-sqrt-Fix-undefined-reference-to-__sqrt_finite.patch \
25 file://0008-__ieee754_sqrt-f-are-now-inline-functions-and-call-o.patch \
26 file://0009-Quote-from-bug-1443-which-explains-what-the-patch-do.patch \
27 file://0010-eglibc-run-libm-err-tab.pl-with-specific-dirs-in-S.patch \
28 file://0011-__ieee754_sqrt-f-are-now-inline-functions-and-call-o.patch \
29 file://0012-sysdeps-gnu-configure.ac-handle-correctly-libc_cv_ro.patch \
30 file://0013-Add-unused-attribute.patch \
31 file://0014-yes-within-the-path-sets-wrong-config-variables.patch \
32 file://0015-timezone-re-written-tzselect-as-posix-sh.patch \
33 file://0016-Remove-bash-dependency-for-nscd-init-script.patch \
34 file://0017-eglibc-Cross-building-and-testing-instructions.patch \
35 file://0018-eglibc-Help-bootstrap-cross-toolchain.patch \
36 file://0019-eglibc-Clear-cache-lines-on-ppc8xx.patch \
37 file://0020-eglibc-Resolve-__fpscr_values-on-SH4.patch \
38 file://0021-eglibc-Install-PIC-archives.patch \
39 file://0022-eglibc-Forward-port-cross-locale-generation-support.patch \
40 file://0023-Define-DUMMY_LOCALE_T-if-not-defined.patch \
41 file://0024-elf-dl-deps.c-Make-_dl_build_local_scope-breadth-fir.patch \
42 file://0025-locale-fix-hard-coded-reference-to-gcc-E.patch \
43 file://0026-reset-dl_load_write_lock-after-forking.patch \
44 file://0027-Acquire-ld.so-lock-before-switching-to-malloc_atfork.patch \
45 file://0028-bits-siginfo-consts.h-enum-definition-for-TRAP_HWBKP.patch \
46 file://0029-Replace-strncpy-with-memccpy-to-fix-Wstringop-trunca.patch \
47 file://0030-plural_c_no_preprocessor_lines.patch \
48"
49
50NATIVESDKFIXES ?= ""
51NATIVESDKFIXES_class-nativesdk = "\
52 file://0001-nativesdk-glibc-Look-for-host-system-ld.so.cache-as-.patch \
53 file://0002-nativesdk-glibc-Fix-buffer-overrun-with-a-relocated-.patch \
54 file://0003-nativesdk-glibc-Raise-the-size-of-arrays-containing-.patch \
55 file://0004-nativesdk-glibc-Allow-64-bit-atomics-for-x86.patch \
56 file://relocate-locales.patch \
57 file://0031-nativesdk-deprecate-libcrypt.patch \
58"
59
60S = "${WORKDIR}/git"
61B = "${WORKDIR}/build-${TARGET_SYS}"
62
63PACKAGES_DYNAMIC = ""
64
65# the -isystem in bitbake.conf screws up glibc do_stage
66BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
67TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
68
69GLIBC_BROKEN_LOCALES = ""
70#
71# We will skip parsing glibc when target system C library selection is not glibc
72# this helps in easing out parsing for non-glibc system libraries
73#
74COMPATIBLE_HOST_libc-musl_class-target = "null"
75
76GLIBCPIE ??= ""
77
78EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
79 --without-cvs --disable-profile \
80 --disable-debug --without-gd \
81 --enable-clocale=gnu \
82 --enable-add-ons=libidn \
83 --with-headers=${STAGING_INCDIR} \
84 --without-selinux \
85 --enable-obsolete-rpc \
86 --enable-obsolete-nsl \
87 --enable-tunables \
88 --enable-bind-now \
89 --enable-stack-protector=strong \
90 --enable-stackguard-randomization \
91 ${GLIBCPIE} \
92 ${GLIBC_EXTRA_OECONF}"
93
94EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
95EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'libc-inet-anl', '--enable-nscd', '--disable-nscd', d)}"
96
97
98do_patch_append() {
99 bb.build.exec_func('do_fix_readlib_c', d)
100}
101
102do_fix_readlib_c () {
103 sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
104}
105
106do_configure () {
107# override this function to avoid the autoconf/automake/aclocal/autoheader
108# calls for now
109# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
110# version check and doesn't really help with anything
111 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
112 find ${S} -name "configure" | xargs touch
113 CPPFLAGS="" oe_runconf
114}
115
116rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
117 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
118 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
119
120do_compile () {
121 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
122 unset LDFLAGS
123 base_do_compile
124 (
125 cd ${S}/sunrpc/rpcsvc
126 for r in ${rpcsvc}; do
127 h=`echo $r|sed -e's,\.x$,.h,'`
128 rm -f $h
129 ${B}/sunrpc/cross-rpcgen -h $r -o $h || bbwarn "${PN}: unable to generate header for $r"
130 done
131 )
132 echo "Adjust ldd script"
133 if [ -n "${RTLDLIST}" ]
134 then
135 prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST="\?\([^"]*\)"\?$#\1#'`
136 if [ "${prevrtld}" != "${RTLDLIST}" ]
137 then
138 sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${prevrtld} ${RTLDLIST}\"#"
139 fi
140 fi
141
142}
143
144require glibc-package.inc
145
146BBCLASSEXTEND = "nativesdk"