blob: f588a1077bfc852de9fc411eae8acf4f5cdc7a5c [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Live image install script for grub-efi"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4SRC_URI = "file://init-install-efi.sh"
5
6PR = "r1"
7
Brad Bishop316dfdd2018-06-25 12:45:53 -04008RDEPENDS_${PN} = "parted e2fsprogs-mke2fs dosfstools util-linux-blkid ${VIRTUAL-RUNTIME_base-utils}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009
10S = "${WORKDIR}"
11
12do_install() {
13 install -m 0755 ${WORKDIR}/init-install-efi.sh ${D}/install-efi.sh
14}
15
16# While this package maybe an allarch due to it being a
17# simple script, reality is that it is Host specific based
18# on the COMPATIBLE_HOST below, which needs to take precedence
19#inherit allarch
20INHIBIT_DEFAULT_DEPS = "1"
21
22FILES_${PN} = " /install-efi.sh "
23
Brad Bishopd7bf8c12018-02-25 22:55:05 -050024COMPATIBLE_HOST = "(i.86.*|x86_64.*|aarch64.*)-linux"