blob: 2fb90a68a8f659996f1d40280a57cf40dcdfc724 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "XML C Parser Library and Toolkit"
2DESCRIPTION = "The XML Parser Library allows for manipulation of XML files. Libxml2 exports Push and Pull type parser interfaces for both XML and HTML. It can do DTD validation at parse time, on a parsed document instance or with an arbitrary DTD. Libxml2 includes complete XPath, XPointer and Xinclude implementations. It also has a SAX like interface, which is designed to be compatible with Expat."
3HOMEPAGE = "http://www.xmlsoft.org/"
4BUGTRACKER = "http://bugzilla.gnome.org/buglist.cgi?product=libxml2"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://Copyright;md5=2044417e2e5006b65a8b9067b683fcf1 \
8 file://hash.c;beginline=6;endline=15;md5=96f7296605eae807670fb08947829969 \
9 file://list.c;beginline=4;endline=13;md5=cdbfa3dee51c099edb04e39f762ee907 \
10 file://trio.c;beginline=5;endline=14;md5=6c025753c86d958722ec76e94cae932e"
11
12DEPENDS = "zlib virtual/libiconv"
13
14SRC_URI = "http://www.xmlsoft.org/sources/libxml2-${PV}.tar.gz;name=libtar \
15 http://www.w3.org/XML/Test/xmlts20080827.tar.gz;name=testtar \
16 file://libxml-64bit.patch \
17 file://ansidecl.patch \
18 file://runtest.patch \
19 file://run-ptest \
20 file://python-sitepackages-dir.patch \
21 file://libxml-m4-use-pkgconfig.patch \
22 file://0001-Make-ptest-run-the-python-tests-if-python-is-enabled.patch \
23 file://fix-execution-of-ptests.patch \
24 "
25
26SRC_URI[libtar.md5sum] = "896608641a08b465098a40ddf51cefba"
27SRC_URI[libtar.sha256sum] = "f63c5e7d30362ed28b38bfa1ac6313f9a80230720b7fb6c80575eeab3ff5900c"
28SRC_URI[testtar.md5sum] = "ae3d1ebe000a3972afa104ca7f0e1b4a"
29SRC_URI[testtar.sha256sum] = "96151685cec997e1f9f3387e3626d61e6284d4d6e66e0e440c209286c03e9cc7"
30
31BINCONFIG = "${bindir}/xml2-config"
32
33PACKAGECONFIG ??= "python \
34 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
35"
36PACKAGECONFIG[python] = "--with-python=${PYTHON},--without-python,python3"
37PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
38
39inherit autotools pkgconfig binconfig-disabled ptest
40
41inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
42
43RDEPENDS_${PN}-ptest += "make ${@bb.utils.contains('PACKAGECONFIG', 'python', 'libgcc python3-core python3-logging python3-shell python3-stringold python3-threading python3-unittest ${PN}-python', '', d)}"
44
45RDEPENDS_${PN}-python += "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3-core', '', d)}"
46
47RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-gconv-ebcdic-us glibc-gconv-ibm1141 glibc-gconv-iso8859-5"
48
49export PYTHON_SITE_PACKAGES="${PYTHON_SITEPACKAGES_DIR}"
50
51# WARNING: zlib is required for RPM use
52EXTRA_OECONF = "--without-debug --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma --with-fexceptions"
53EXTRA_OECONF_class-native = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
54EXTRA_OECONF_class-nativesdk = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
55EXTRA_OECONF_linuxstdbase = "--with-debug --with-legacy --with-docbook --with-c14n --without-lzma --with-zlib"
56
57python populate_packages_prepend () {
58 # autonamer would call this libxml2-2, but we don't want that
59 if d.getVar('DEBIAN_NAMES'):
60 d.setVar('PKG_libxml2', '${MLPREFIX}libxml2')
61}
62
63PACKAGES += "${PN}-utils ${PN}-python"
64
65FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"
66FILES_${PN}-dev += "${libdir}/xml2Conf.sh ${libdir}/cmake/*"
67FILES_${PN}-utils += "${bindir}/*"
68FILES_${PN}-python += "${PYTHON_SITEPACKAGES_DIR}"
69
70do_configure_prepend () {
71 # executables take longer to package: these should not be executable
72 find ${WORKDIR}/xmlconf/ -type f -exec chmod -x {} \+
73}
74
75do_compile_ptest() {
76 oe_runmake check-am
77}
78
79do_install_ptest () {
80 cp -r ${WORKDIR}/xmlconf ${D}${PTEST_PATH}
81 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
82 sed -i -e 's|^\(PYTHON = \).*|\1${USRBINPATH}/${PYTHON_PN}|' \
83 ${D}${PTEST_PATH}/python/tests/Makefile
84 grep -lrZ '#!/usr/bin/python' ${D}${PTEST_PATH}/python |
85 xargs -0 sed -i -e 's|/usr/bin/python|${USRBINPATH}/${PYTHON_PN}|'
86 fi
87 #Remove build host references from various Makefiles
88 find "${D}${PTEST_PATH}" -name Makefile -type f -exec \
89 sed -i \
90 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
91 -e 's|${DEBUG_PREFIX_MAP}||g' \
92 -e 's:${HOSTTOOLS_DIR}/::g' \
93 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
94 -e 's:${RECIPE_SYSROOT}::g' \
95 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
96 -e '/^RELDATE/d' \
97 {} +
98}
99
100do_install_append_class-native () {
101 # Docs are not needed in the native case
102 rm ${D}${datadir}/gtk-doc -rf
103}
104
105BBCLASSEXTEND = "native nativesdk"