blob: 76d4312d88129923d38805a962f002f60462ae23 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "manage symlinks in /etc/rcN.d"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05002HOMEPAGE = "http://github.com/philb/update-rc.d/"
Patrick Williamsc0f7c042017-02-23 20:41:17 -06003DESCRIPTION = "update-rc.d is a utility that allows the management of symlinks to the initscripts in the /etc/rcN.d directory structure."
Patrick Williamsc124f4f2015-09-15 14:41:29 -05004SECTION = "base"
5
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://update-rc.d;beginline=5;endline=15;md5=148a48321b10eb37c1fa3ee02b940a75"
8
9PR = "r5"
10
11# Revision corresponding to tag update-rc.d_0.7
12SRCREV = "eca680ddf28d024954895f59a241a622dd575c11"
13
14SRC_URI = "git://github.com/philb/update-rc.d.git \
15 file://add-verbose.patch \
16 file://check-if-symlinks-are-valid.patch \
17 file://fix-to-handle-priority-numbers-correctly.patch \
18 "
Brad Bishop316dfdd2018-06-25 12:45:53 -040019UPSTREAM_CHECK_COMMITS = "1"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020
21S = "${WORKDIR}/git"
22
23inherit allarch
24
25do_compile() {
26}
27
28do_install() {
29 install -d ${D}${sbindir}
30 install -m 0755 ${S}/update-rc.d ${D}${sbindir}/update-rc.d
31}
32
33BBCLASSEXTEND = "native"