blob: 55cc98c20029c8be994e2c5a3f08a31b1bfc0cac [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001MAJOR_VERSION = "2.32"
2require util-linux.inc
3
4# To support older hosts, we need to patch and/or revert
5# some upstream changes. Only do this for native packages.
6OLDHOST = ""
7OLDHOST_class-native = "file://util-linux-native-qsort.patch"
8
9SRC_URI += "file://configure-sbindir.patch \
10 file://runuser.pamd \
11 file://runuser-l.pamd \
12 ${OLDHOST} \
13 file://ptest.patch \
14 file://run-ptest \
15 file://display_testname_for_subtest.patch \
16 file://avoid_parallel_tests.patch \
17"
18SRC_URI[md5sum] = "e0d8a25853f88cd15ff557e5d8cb4ea7"
19SRC_URI[sha256sum] = "6c7397abc764e32e8159c2e96042874a190303e77adceb4ac5bd502a272a4734"
20
21CACHED_CONFIGUREVARS += "scanf_cv_alloc_modifier=ms"
22
23EXTRA_OECONF_class-native = "${SHARED_EXTRA_OECONF} \
24 --disable-fallocate \
25 --disable-use-tty-group \
26"
27EXTRA_OECONF_class-nativesdk = "${SHARED_EXTRA_OECONF} \
28 --disable-fallocate \
29 --disable-use-tty-group \
30"