blob: 14ac22ee64389e862b6741a3eab8aabbeb0b4918 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Utilities and libraries for handling compiled object files"
2HOMEPAGE = "https://sourceware.org/elfutils"
3SECTION = "base"
4LICENSE = "(GPLv3 & Elfutils-Exception)"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6DEPENDS = "libtool bzip2 zlib virtual/libintl"
7DEPENDS_append_libc-musl = " argp-standalone fts "
Brad Bishop316dfdd2018-06-25 12:45:53 -04008# The Debian patches below are from:
9# http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.168-0.2.debian.tar.xz
10SRC_URI = "https://sourceware.org/elfutils/ftp/${PV}/${BP}.tar.bz2 \
11 file://0001-dso-link-change.patch \
12 file://0002-Fix-elf_cvt_gunhash-if-dest-and-src-are-same.patch \
13 file://0003-fixheadercheck.patch \
14 file://0004-Disable-the-test-to-convert-euc-jp.patch \
15 file://0005-fix-a-stack-usage-warning.patch \
16 file://0006-Fix-build-on-aarch64-musl.patch \
17 file://0007-Fix-control-path-where-we-have-str-as-uninitialized-.patch \
18 file://0001-libasm-may-link-with-libbz2-if-found.patch \
19 file://debian/hppa_backend.diff \
20 file://debian/arm_backend.diff \
21 file://debian/mips_backend.patch \
22 file://debian/mips_readelf_w.patch \
23 file://debian/0001-Ignore-differences-between-mips-machine-identifiers.patch \
24 file://debian/0002-Add-support-for-mips64-abis-in-mips_retval.c.patch \
25 file://debian/0003-Add-mips-n64-relocation-format-hack.patch \
26 file://0001-Use-fallthrough-attribute.patch \
27 file://0001-Ensure-that-packed-structs-follow-the-gcc-memory-lay.patch \
28 "
29SRC_URI_append_libc-musl = " file://0008-build-Provide-alternatives-for-glibc-assumptions-hel.patch"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050030SRC_URI[md5sum] = "03599aee98c9b726c7a732a2dd0245d5"
31SRC_URI[sha256sum] = "1f844775576b79bdc9f9c717a50058d08620323c1e935458223a12f249c9e066"
32
Brad Bishopd7bf8c12018-02-25 22:55:05 -050033inherit autotools gettext
34
35EXTRA_OECONF = "--program-prefix=eu- --without-lzma"
36EXTRA_OECONF_append_class-native = " --without-bzlib"
37
38do_install_append() {
39 if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then
40 rm -f ${D}${bindir}/eu-objdump
41 fi
42}
43
44EXTRA_OEMAKE_class-native = ""
45EXTRA_OEMAKE_class-nativesdk = ""
46
47ALLOW_EMPTY_${PN}_libc-musl = "1"
48
49BBCLASSEXTEND = "native nativesdk"
50
51# Package utilities separately
52PACKAGES =+ "${PN}-binutils libelf libasm libdw"
53FILES_${PN}-binutils = "\
54 ${bindir}/eu-addr2line \
55 ${bindir}/eu-ld \
56 ${bindir}/eu-nm \
57 ${bindir}/eu-readelf \
58 ${bindir}/eu-size \
59 ${bindir}/eu-strip"
60
61FILES_libelf = "${libdir}/libelf-${PV}.so ${libdir}/libelf.so.*"
62FILES_libasm = "${libdir}/libasm-${PV}.so ${libdir}/libasm.so.*"
63FILES_libdw = "${libdir}/libdw-${PV}.so ${libdir}/libdw.so.* ${libdir}/elfutils/lib*"
64# Some packages have the version preceeding the .so instead properly
65# versioned .so.<version>, so we need to reorder and repackage.
66#FILES_${PN} += "${libdir}/*-${PV}.so ${base_libdir}/*-${PV}.so"
67#FILES_SOLIBSDEV = "${libdir}/libasm.so ${libdir}/libdw.so ${libdir}/libelf.so"
68
69# The package contains symlinks that trip up insane
70INSANE_SKIP_${MLPREFIX}libdw = "dev-so"