blob: 6a81dab26502504adc3f0eefeb6401abc52aa90b [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001HOMEPAGE = "http://mesonbuild.com"
2SUMMARY = "A high performance build system"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7SRC_URI = "https://github.com/mesonbuild/meson/releases/download/${PV}/${BP}.tar.gz \
8 file://0001-gtkdoc-fix-issues-that-arise-when-cross-compiling.patch \
9 file://0002-gobject-introspection-determine-g-ir-scanner-and-g-i.patch \
10 file://0001-Linker-rules-move-cross_args-in-front-of-output_args.patch \
11 file://0003-native_bindir.patch \
12 "
13SRC_URI[md5sum] = "82b1198bf714b5a4da84bfe8376c79cc"
14SRC_URI[sha256sum] = "2ea1a721574adb23160b6481191bcc1173f374e02b0ff3bb0ae85d988d97e4fa"
15UPSTREAM_CHECK_URI = "https://github.com/mesonbuild/meson/releases"
16
17inherit setuptools3
18
19RDEPENDS_${PN} = "ninja python3-core python3-modules"
20
21BBCLASSEXTEND = "native"