blob: e5ab7a33c7080d833db62c6ca32e2e8e900e244f [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Skip tests when modules not available"
2DESCRIPTION = "Skip test scripts if modules are not available. \
3The requested modules will be loaded, and optionally have their versions \
4checked. If the module is missing, the test script will be skipped. Modules \
5that are found but fail to compile will exit with an error rather than skip."
6
7HOMEPAGE = "https://metacpan.org/release/Test-Needs"
8SECTION = "libs"
9LICENSE = "Artistic-1.0 | GPL-1.0+"
10
11CPAN_NAME = "Test-Needs"
12CPAN_AUTHOR = "HAARG"
13
14LIC_FILES_CHKSUM = "file://README;md5=3f3ccd21a0a48aa313db212cc3b1bc09;beginline=81;endline=82"
15
16DEPENDS += "perl"
17
18SRC_URI = "http://www.cpan.org/authors/id/H/HA/${CPAN_AUTHOR}/${CPAN_NAME}-${PV}.tar.gz"
19
20SRC_URI[md5sum] = "356634a56c99282e8059f290f5d534c8"
21SRC_URI[sha256sum] = "5a4f33983586edacdbe00a3b429a9834190140190dab28d0f873c394eb7df399"
22
23S = "${WORKDIR}/${CPAN_NAME}-${PV}"
24
25inherit cpan ptest-perl
26
27RDEPENDS_${PN}-ptest += "perl-module-test-more"
28
29BBCLASSEXTEND = "native"