blob: 53fd6dcf274f70ceccfd6d12d1b1659648b9ae78 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "The PyPA recommended tool for installing Python packages"
2HOMEPAGE = "https://pypi.python.org/pypi/pip"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=25fba45109565f87de20bae85bc39452"
6
7DEPENDS += "python3 python3-setuptools-native"
8
9SRC_URI[md5sum] = "2fddd680422326b9d1fbf56112cf341d"
10SRC_URI[sha256sum] = "88110a224e9d30e5d76592a0b2130ef10e7e67a6426e8617bb918fffbfe91fe5"
11
12inherit pypi distutils3
13
14DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
15
16do_install_prepend() {
17 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
18}
19
20# Use setuptools site.py instead, avoid shared state issue
21do_install_append() {
22 rm ${D}${PYTHON_SITEPACKAGES_DIR}/site.py
23 rm ${D}${PYTHON_SITEPACKAGES_DIR}/__pycache__/site.cpython-*.pyc
24
25 # Install as pip3 and leave pip2 as default
26 rm ${D}/${bindir}/pip
27
28 # Installed eggs need to be passed directly to the interpreter via a pth file
29 echo "./${PYPI_PACKAGE}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/${PYPI_PACKAGE}-${PV}.pth
30
31 # Make sure we use /usr/bin/env python3
32 for PYTHSCRIPT in `grep -rIl ${bindir} ${D}${bindir}/pip3*`; do
33 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
34 done
35}
36
37RDEPENDS_${PN} = "\
38 python3-compile \
39 python3-io \
40 python3-html \
41 python3-json \
42 python3-netserver \
43 python3-setuptools \
44 python3-unixadmin \
45 python3-xmlrpc \
46"
47
48BBCLASSEXTEND = "native nativesdk"