blob: ab70ea98a32643af80269109cec9201bd7f394cc [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "This is a simple example recipe that cross-compiles a Go program."
2SECTION = "examples"
3HOMEPAGE = "https://golang.org/"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05004
Brad Bishopd7bf8c12018-02-25 22:55:05 -05005LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007
Brad Bishopd7bf8c12018-02-25 22:55:05 -05008SRC_URI = "git://${GO_IMPORT}"
9SRCREV = "46695d81d1fae905a270fb7db8a4d11a334562fe"
Brad Bishop316dfdd2018-06-25 12:45:53 -040010UPSTREAM_CHECK_COMMITS = "1"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012GO_IMPORT = "github.com/golang/example"
13GO_INSTALL = "${GO_IMPORT}/hello"
14
15inherit go
16
17# This is just to make clear where this example is
18do_install_append() {
19 mv ${D}${bindir}/hello ${D}${bindir}/${BPN}
Brad Bishop6e60e8b2018-02-01 10:27:11 -050020}