blob: 6e6da9c3c56a612d32b802c67a4379cb033179f1 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "A parallel implementation of gzip"
2DESCRIPTION = "pigz, which stands for parallel implementation of gzip, is a \
3fully functional replacement for gzip that exploits multiple processors and \
4multiple cores to the hilt when compressing data. pigz was written by Mark \
5Adler, and uses the zlib and pthread libraries."
6HOMEPAGE = "http://zlib.net/pigz/"
7SECTION = "console/utils"
8LICENSE = "Zlib & Apache-2.0"
9LIC_FILES_CHKSUM = "file://pigz.c;md5=9ae6dee8ceba9610596ed0ada493d142;beginline=7;endline=21"
10
11SRC_URI = "http://zlib.net/${BPN}/fossils/${BP}.tar.gz"
12SRC_URI[md5sum] = "def2f6e19d9d8231445adc1349d346df"
13SRC_URI[sha256sum] = "a4f816222a7b4269bd232680590b579ccc72591f1bb5adafcd7208ca77e14f73"
14# Point this at the homepage in case /fossils/ isn't updated
15UPSTREAM_CHECK_URI = "http://zlib.net/${BPN}/"
16UPSTREAM_CHECK_REGEX = "pigz-(?P<pver>.*)\.tar"
17
18DEPENDS = "zlib"
19
20EXTRA_OEMAKE = "-e MAKEFLAGS="
21
22do_install() {
23 # Install files into /bin (FHS), which is typical place for gzip
24 install -d ${D}${base_bindir}
25 install ${B}/pigz ${D}${base_bindir}/pigz
26 ln -nsf pigz ${D}${base_bindir}/unpigz
27 ln -nsf pigz ${D}${base_bindir}/pigzcat
28}
29
30BBCLASSEXTEND = "native nativesdk"