blob: 19fe3cc44274ad4d4c094dafd57310e88fd7a04f [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "JSON-GLib implements a full JSON parser using GLib and GObject"
2DESCRIPTION = "Use JSON-GLib it is possible to parse and generate valid JSON\
3 data structures, using a DOM-like API. JSON-GLib also offers GObject \
4integration, providing the ability to serialize and deserialize GObject \
5instances to and from JSON data types."
6HOMEPAGE = "http://live.gnome.org/JsonGlib"
7
8LICENSE = "LGPLv2.1"
9LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
10
11DEPENDS = "glib-2.0"
12
13SRC_URI[archive.md5sum] = "35107e23a7bbbc70f31c34f7b9adf1c3"
14SRC_URI[archive.sha256sum] = "2d7709a44749c7318599a6829322e081915bdc73f5be5045882ed120bb686dc8"
15
16GNOMEBASEBUILDCLASS = "meson"
17inherit gnomebase lib_package gobject-introspection gtk-doc gettext
18
19# This builds both API docs (via gtk-doc) and manpages
20GTKDOC_ENABLE_FLAG = "-Ddocs=true"
21GTKDOC_DISABLE_FLAG = "-Ddocs=false"
22
23GI_ENABLE_FLAG = "-Dintrospection=true"
24GI_DISABLE_FLAG = "-Dintrospection=false"
25
26EXTRA_OEMESON_append_class-target = " ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '${GTKDOC_ENABLE_FLAG}', \
27 '${GTKDOC_DISABLE_FLAG}', d)} "
28EXTRA_OEMESON_append_class-target = " ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '${GI_ENABLE_FLAG}', \
29 '${GI_DISABLE_FLAG}', d)} "
30
31do_install_append() {
32 # FIXME: these need to be provided via ptest
33 rm -rf ${D}${datadir}/installed-tests ${D}${libexecdir}
34}
35
36BBCLASSEXTEND = "native nativesdk"
37
38# Currently it's not possible to disable gettext in Meson, so we need to force
39# this back on.
40USE_NLS_class-native = "yes"