blob: 4201faf672bb7e578cf8869f992615e044364146 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# This recipe tracks the linux-yocto-dev repository as its upstream source.
2# Since this tree is frequently updated, and periodically rebuilt, AUTOREV is
3# used to track its contents.
4#
5# This recipe is just like other linux-yocto variants, with the only difference
6# being that to avoid network access during initial parsing, static SRCREVs are
7# provided and overridden if the preferred kernel provider is linux-yocto-dev.
8#
9# To enable this recipe, set PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-dev"
10
11inherit kernel
12require recipes-kernel/linux/linux-yocto.inc
13
14# provide this .inc to set specific revisions
15include recipes-kernel/linux/linux-yocto-dev-revisions.inc
16
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017KBRANCH = "standard/base"
18KMETA = "kernel-meta"
19
20SRC_URI = "git://git.yoctoproject.org/linux-yocto-dev.git;branch=${KBRANCH};name=machine \
21 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=master;destsuffix=${KMETA}"
22
23# Set default SRCREVs. Both the machine and meta SRCREVs are statically set
24# to the korg v3.7 tag, and hence prevent network access during parsing. If
25# linux-yocto-dev is the preferred provider, they will be overridden to
26# AUTOREV in following anonymous python routine and resolved when the
27# variables are finalized.
28SRCREV_machine ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-yocto-dev", "${AUTOREV}", "29594404d7fe73cd80eaa4ee8c43dcc53970c60e", d)}'
29SRCREV_meta ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-yocto-dev", "${AUTOREV}", "29594404d7fe73cd80eaa4ee8c43dcc53970c60e", d)}'
30
Brad Bishop316dfdd2018-06-25 12:45:53 -040031LINUX_VERSION ?= "4.16-rc+"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050032LINUX_VERSION_EXTENSION ?= "-yoctodev-${LINUX_KERNEL_TYPE}"
33PV = "${LINUX_VERSION}+git${SRCPV}"
34
Brad Bishop316dfdd2018-06-25 12:45:53 -040035DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
36DEPENDS += "openssl-native util-linux-native"
37
Patrick Williamsc124f4f2015-09-15 14:41:29 -050038COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemumips64|qemux86-64)"
39
Patrick Williamsc0f7c042017-02-23 20:41:17 -060040KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"
41
Patrick Williamsc124f4f2015-09-15 14:41:29 -050042# Functionality flags
43KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/taskstats/taskstats.scc"
44KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050045KERNEL_FEATURES_append_qemuall=" cfg/virtio.scc"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050046KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
47KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"
48KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"
49
Brad Bishop6e60e8b2018-02-01 10:27:11 -050050KERNEL_VERSION_SANITY_SKIP = "1"