blob: 1eaa261f75a554dbb94c40816796cd6f25a814f1 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Collection of simple PIN or passphrase entry dialogs"
2DESCRIPTION = "\
3 Pinentry is a collection of simple PIN or passphrase entry dialogs which \
4 utilize the Assuan protocol as described by the aegypten project; see \
5 http://www.gnupg.org/aegypten/ for details."
6
7HOMEPAGE = "http://www.gnupg.org/related_software/pinentry/index.en.html"
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=cbbd794e2a0a289b9dfcc9f513d1996e"
10
11inherit autotools pkgconfig
12
13DEPENDS = "gettext-native libassuan libgpg-error"
14
15UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
16SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
17 file://libassuan_pkgconf.patch \
18 file://gpg-error_pkconf.patch \
19"
20
21SRC_URI[md5sum] = "3829315cb0a1e9cedc05ffe6def7a2c6"
22SRC_URI[sha256sum] = "68076686fa724a290ea49cdf0d1c0c1500907d1b759a3bcbfbec0293e8f56570"
23
24EXTRA_OECONF = "--disable-rpath --disable-dependency-tracking \
25 --disable-pinentry-qt5 \
26"
27
28PACKAGECONFIG ??= "ncurses libcap"
29
30PACKAGECONFIG[ncurses] = "--enable-ncurses --with-ncurses-include-dir=${STAGING_INCDIR}, --disable-ncurses, ncurses"
31PACKAGECONFIG[libcap] = "--with-libcap, --without-libcap, libcap"
32PACKAGECONFIG[qt] = "--enable-pinentry-qt, --disable-pinentry-qt, qt4-x11"
33PACKAGECONFIG[gtk2] = "--enable-pinentry-gtk2, --disable-pinentry-gtk2, gtk+ glib-2.0"
34
35#To use libsecret, add meta-gnome
36PACKAGECONFIG[secret] = "--enable-libsecret, --disable-libsecret, libsecret"
37
38BBCLASSEXTEND = "native"