blob: bf8cb90178094ff2d777463cba1193834aab319f [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Fast, multi-threaded malloc() and nifty performance analysis tools"
2HOMEPAGE = "https://github.com/gperftools/gperftools"
Andrew Geissler32b11992021-03-31 13:37:05 -05003DESCRIPTION = "The gperftools, previously called google-perftools, package contains some \
4utilities to improve and analyze the performance of C++ programs. \
5Included are an optimized thread-caching malloc() and cpu and heap profiling utilities. \
6"
7
Andrew Geissler82c905d2020-04-13 13:39:40 -05008LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://COPYING;md5=762732742c73dc6c7fbe8632f06c059a"
10
Andrew Geissler32b11992021-03-31 13:37:05 -050011DEPENDS_append_libc-musl = " libucontext"
12
13SRCREV = "f7c6fb6c8e99d6b1b725e5994373bcd19ffdf8fd"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014SRC_URI = "git://github.com/gperftools/gperftools \
15 file://0001-Support-Atomic-ops-on-clang.patch \
16 file://0001-fix-build-with-musl-libc.patch \
17 file://0001-disbale-heap-checkers-and-debug-allocator-on-musl.patch \
18 file://disable_libunwind_aarch64.patch \
19 file://sgidef.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050020 "
21
Andrew Geissler32b11992021-03-31 13:37:05 -050022SRC_URI_append_libc-musl = " file://ppc-musl.patch"
23
Andrew Geissler82c905d2020-04-13 13:39:40 -050024inherit autotools
25
26S = "${WORKDIR}/git"
27
28# On mips, we have the following error.
29# do_page_fault(): sending SIGSEGV to ls for invalid read access from 00000008
30# Segmentation fault (core dumped)
31COMPATIBLE_HOST_mipsarch = "null"
32COMPATIBLE_HOST_riscv64 = "null"
33COMPATIBLE_HOST_riscv32 = "null"
34
35# Disable thumb1
36# {standard input}: Assembler messages:
37# {standard input}:434: Error: lo register required -- `ldr pc,[sp]'
38# Makefile:4538: recipe for target 'src/base/libtcmalloc_la-linuxthreads.lo' failed
39ARM_INSTRUCTION_SET_armv5 = "arm"
40ARM_INSTRUCTION_SET_toolchain-clang_arm = "arm"
41
Andrew Geissler32b11992021-03-31 13:37:05 -050042EXTRA_OECONF_append_libc-musl_powerpc64le = " --disable-cpu-profiler --disable-heap-profiler --disable-heap-checker"
Andrew Geissler82c905d2020-04-13 13:39:40 -050043PACKAGECONFIG ?= "libunwind static"
44PACKAGECONFIG_remove_arm_libc-musl = "libunwind"
45PACKAGECONFIG_remove_riscv64 = "libunwind"
46PACKAGECONFIG_remove_riscv32 = "libunwind"
47
48PACKAGECONFIG[libunwind] = "--enable-libunwind,--disable-libunwind,libunwind"
49PACKAGECONFIG[static] = "--enable-static,--disable-static,"
50
51PACKAGE_BEFORE_PN += "libtcmalloc-minimal"
52FILES_libtcmalloc-minimal = "${libdir}/libtcmalloc_minimal*${SOLIBS} ${libdir}/libtcmalloc_minimal_debug*${SOLIBS}"
53
54# pprof tool requires Getopt::long and POSIX perl5 modules.
55# Also runs `objdump` on each cpuprofile data file
Andrew Geissler32b11992021-03-31 13:37:05 -050056RDEPENDS_${PN} += " \
57 binutils \
58 curl \
59 perl-module-carp \
60 perl-module-cwd \
61 perl-module-getopt-long \
62 perl-module-overloading \
63 perl-module-posix \
64"
Andrew Geissler82c905d2020-04-13 13:39:40 -050065
66RDEPENDS_${PN} += "libtcmalloc-minimal (= ${EXTENDPKGV})"