blob: 0d232dcabb7a37e9dbc3dece5153b9394bb0aa82 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Backport of functools.lru_cache from Python 3.3"
2HOMEPAGE = "https://github.com/jaraco/backports.functools_lru_cache"
3SECTION = "devel/python"
4LICENSE = "MIT"
Andrew Geissler32b11992021-03-31 13:37:05 -05005LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6"
Andrew Geissler82c905d2020-04-13 13:39:40 -05006
7PYPI_PACKAGE = "backports.functools_lru_cache"
8
Andrew Geissler32b11992021-03-31 13:37:05 -05009SRC_URI[sha256sum] = "d84e126e2a29e4fde8931ff8131240bbf30a0e7dbcc3897a8dbd8ea5ac11419c"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010
11DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
12
Andrew Geisslerd221e032020-07-10 16:13:21 -050013inherit pypi setuptools3 ptest
14
15SRC_URI += " \
16 file://run-ptest \
17"
18
19RDEPENDS_${PN}-ptest += " \
20 ${PYTHON_PN}-pytest \
21"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26}
Andrew Geissler82c905d2020-04-13 13:39:40 -050027
28RDEPENDS_${PN} += "\
29 ${PYTHON_PN}-pickle \
30 ${PYTHON_PN}-threading \
31 "