blob: da571d3a2ba0437ae4abd722b0710d9df08ebaaf [file] [log] [blame]
Andrew Geissler97771a32021-03-05 15:23:11 -06001DESCRIPTION = "Google gRPC tools"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515"
7
8inherit pypi setuptools3
9
10DEPENDS += "${PYTHON_PN}-grpcio"
11
12SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch"
13
Andrew Geissler32b11992021-03-31 13:37:05 -050014SRC_URI[sha256sum] = "80ef584f7b917f575e4b8f2ec59cd4a4d98c2046e801a735f3136b05742a36a6"
Andrew Geissler97771a32021-03-05 15:23:11 -060015
16RDEPENDS_${PN} = "${PYTHON_PN}-grpcio"
17
18BBCLASSEXTEND = "native nativesdk"
Andrew Geissler32b11992021-03-31 13:37:05 -050019
20# Needs abseil-cpp which does not build for ppc64le/musl
21COMPATIBLE_HOST_libc-musl_powerpc64le = "null"
22