blob: 8af0fef60c23e32ae62c98a6ddd304a30757818c [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "The Swiss Army knife of Python web development"
2DESCRIPTION = "\
3Werkzeug started as simple collection of various utilities for WSGI \
4applications and has become one of the most advanced WSGI utility modules. \
5It includes a powerful debugger, full featured request and response objects, \
6HTTP utilities to handle entity tags, cache control headers, HTTP dates, \
7cookie handling, file uploads, a powerful URL routing system and a bunch \
8of community contributed addon modules."
9HOMEPAGE = "http://werkzeug.pocoo.org/"
Andrew Geissler32b11992021-03-31 13:37:05 -050010LICENSE = "BSD-3-Clause"
Andrew Geissler82c905d2020-04-13 13:39:40 -050011LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
12
13PYPI_PACKAGE = "Werkzeug"
14
15SRC_URI[md5sum] = "5d499cfdd30de5d9c946994783772efd"
16SRC_URI[sha256sum] = "6c80b1e5ad3665290ea39320b91e1be1e0d5f60652b964a3070216de83d2e47c"
17
18inherit pypi setuptools3
19
20CLEANBROKEN = "1"
21
22RDEPENDS_${PN} += " \
23 ${PYTHON_PN}-datetime \
24 ${PYTHON_PN}-difflib \
25 ${PYTHON_PN}-email \
26 ${PYTHON_PN}-html \
27 ${PYTHON_PN}-io \
28 ${PYTHON_PN}-json \
Andrew Geissler7f40b712020-05-15 14:09:53 -050029 ${PYTHON_PN}-logging \
Andrew Geissler82c905d2020-04-13 13:39:40 -050030 ${PYTHON_PN}-netclient \
31 ${PYTHON_PN}-netserver \
32 ${PYTHON_PN}-numbers \
33 ${PYTHON_PN}-pkgutil \
34 ${PYTHON_PN}-pprint \
35 ${PYTHON_PN}-simplejson \
36 ${PYTHON_PN}-threading \
37 ${PYTHON_PN}-unixadmin \
38 ${PYTHON_PN}-misc \
39"