blob: 2f7c021397cf9cab747e4d1846c7d83a056ccd65 [file] [log] [blame]
Andrew Geissler5082cc72023-09-11 08:41:39 -04001SUMMARY = "A simple GNOME application to access virtual machines."
2SECTION = "network"
3LICENSE = "LGPL-2.1-or-later"
4LIC_FILES_CHKSUM = "file://copyright;md5=a65e9b0c9f78617732f09f68fc4ef79a"
5
6GNOMEBASEBUILDCLASS = "meson"
7
8REQUIRED_DISTRO_FEATURES += "gobject-introspection-data"
9
10DEPENDS = " \
11 glib-2.0 \
12 desktop-file-utils-native \
13 libarchive \
14 libgudev \
15 libhandy \
16 libosinfo \
17 libsecret \
18 libsoup \
19 libvirt-glib \
20 mtools \
21 spice-gtk \
22 tracker \
23 webkitgtk3 \
24 appstream-glib-native \
25 spice-protocol \
26 yelp-tools \
27"
28
29RDEPENDS:${PN} = "glib-2.0-dev libvirt-virsh qemu-common qemu-system-x86-64 genisoimage"
30
31inherit gnomebase gsettings pkgconfig mime-xdg gtk-icon-cache gobject-introspection vala features_check
32
33SRC_URI[archive.sha256sum] = "9dd389c149d0c0fa57456ec363d51a88255f945558fb9df42894ce78ef85df89"
34
35GIR_MESON_OPTION = ""
36
37FILES:${PN} += "${datadir}"
38
39INSANE_SKIP:${PN} = "dev-deps"