blob: f45bfc0efd222959d4d6eecf1269674845529a0b [file] [log] [blame]
Patrick Williams2a254922023-08-11 09:48:11 -05001SUMMARY = "Simple construction, analysis and modification of binary data."
2HOMEPAGE = "https://github.com/scott-griffiths/bitstring"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=661f450e2c0aef39b4b15597333444a7"
5
Andrew Geissler5082cc72023-09-11 08:41:39 -04006SRC_URI[sha256sum] = "a9c97fdf9fe38f27ea0ac2b4cf2a3f5bce5ccc23b863082582b9f48b22274528"
Patrick Williams2a254922023-08-11 09:48:11 -05007
8PYPI_PACKAGE = "bitstring"
9
10inherit pypi python_poetry_core
11
12RDEPENDS:${PN} = "\
13 ${PYTHON_PN}-core \
14 ${PYTHON_PN}-io \
15 ${PYTHON_PN}-mmap \
16 ${PYTHON_PN}-numbers \
17"
18
19BBCLASSEXTEND = "native nativesdk"