blob: e4ac403eb5398b780c9b3214ac99421529a244d2 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "Non-validating SQL parser module"
2HOMEPAGE = "http://pypi.python.org/pypi/sqlparse"
3SECTION = "devel/python"
Andrew Geissler5199d832021-09-24 16:47:35 -05004LICENSE = "BSD-3-Clause"
Andrew Geissler82c905d2020-04-13 13:39:40 -05005LIC_FILES_CHKSUM = "file://LICENSE;md5=2b136f573f5386001ea3b7b9016222fc"
6
7SRC_URI += "file://0001-sqlparse-change-shebang-to-python3.patch \
8 file://run-ptest \
9 "
10
Patrick Williams2a254922023-08-11 09:48:11 -050011SRC_URI[sha256sum] = "d446183e84b8349fa3061f0fe7f06ca94ba65b426946ffebe6e3e8295332420c"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
13export BUILD_SYS
14export HOST_SYS
15
Patrick Williams2a254922023-08-11 09:48:11 -050016inherit pypi ptest python_flit_core
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
Patrick Williams213cb262021-08-07 19:21:33 -050018RDEPENDS:${PN}-ptest += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050019 ${PYTHON_PN}-pytest \
20 ${PYTHON_PN}-unixadmin \
21"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26}
27
28BBCLASSEXTEND = "native nativesdk"