blob: c55682e2eaff6656ac6dfe21e9fe2f0de29eadd0 [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001SUMMARY = "pyelftools is a pure-Python library for parsing and analyzing ELF files and DWARF debugging information"
Patrick Williams92b42cb2022-09-03 06:53:57 -05002HOMEPAGE = "https://github.com/eliben/pyelftools"
3SECTION = "devel/python"
4LICENSE = "PD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=5ce2a2b07fca326bc7c146d10105ccfc"
6
7SRC_URI[sha256sum] = "ec761596aafa16e282a31de188737e5485552469ac63b60cfcccf22263fd24ff"
8
9PYPI_PACKAGE = "pyelftools"
10
11inherit pypi setuptools3
12
13BBCLASSEXTEND = "native"
14
15RDEPENDS:${PN} += "${PYTHON_PN}-debugger ${PYTHON_PN}-pprint"