blob: 2970767ff32313b7647edb21965ef0e5efe47fed [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Vulkan Header files and API registry"
2DESCRIPTION = "Vulkan is a 3D graphics and compute API providing cross-platform access \
3to modern GPUs with low overhead and targeting realtime graphics applications such as \
4games and interactive media. This package contains the development headers \
5for packages wanting to make use of Vulkan."
6HOMEPAGE = "https://www.khronos.org/vulkan/"
7BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Headers"
8SECTION = "libs"
9
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
12SRC_URI = "git://github.com/KhronosGroup/Vulkan-Headers.git;branch=main;protocol=https"
13
Patrick Williams520786c2023-06-25 16:20:36 -050014SRCREV = "9e61870ecbd32514113b467e0a0c46f60ed222c7"
Andrew Geissler517393d2023-01-13 08:55:19 -060015
16S = "${WORKDIR}/git"
17
18inherit cmake
19
20FILES:${PN} += "${datadir}/vulkan"
Patrick Williams864cc432023-02-09 14:54:44 -060021RDEPENDS:${PN} += "python3-core"
Andrew Geissler517393d2023-01-13 08:55:19 -060022
Andrew Geissler028142b2023-05-05 11:29:21 -050023# These recipes need to be updated in lockstep with each other:
24# glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools
25# The tags versions should always be sdk-x.y.z, as this is what
26# upstream considers a release.
Andrew Geissler517393d2023-01-13 08:55:19 -060027UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"