Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 1 | SUMMARY = "A header only library for creating and validating json web tokens in c++" |
| 2 | HOMEPAGE = "https://thalhammer.github.io/jwt-cpp/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8325a5ce4414c65ffdda392e0d96a9ff" |
| 6 | |
| 7 | SRC_URI = "git://github.com/Thalhammer/jwt-cpp.git;branch=master;protocol=https \ |
| 8 | " |
| 9 | |
| 10 | SRCREV = "4a537e969891dde542ad8b1a4a214955a83be29f" |
| 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | DEPENDS = "openssl" |
| 15 | |
| 16 | inherit cmake |
| 17 | |
| 18 | EXTRA_OECMAKE += "-DJWT_BUILD_EXAMPLES=OFF -DJWT_CMAKE_FILES_INSTALL_DIR=${libdir}/cmake" |