Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | DESCRIPTION = "C++ client for Redis based on hiredis" |
| 2 | HOMEPAGE = "https://github.com/sewenew/redis-plus-plus" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 6 | |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 7 | SRC_URI = "git://github.com/sewenew/redis-plus-plus;branch=master;protocol=https" |
| 8 | SRCREV = "58084931ed1a056d91fe96da7b9ea81fa023560a" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 9 | |
| 10 | S = "${WORKDIR}/git" |
| 11 | |
| 12 | inherit cmake |
| 13 | |
| 14 | DEPENDS += "hiredis" |
| 15 | |
| 16 | RDEPENDS:${PN} += "hiredis" |
| 17 | |
| 18 | FILES_SOLIBSDEV = "" |
| 19 | FILES:${PN} += " ${libdir}/libredis++.so*" |
| 20 | |
| 21 | INSANE_SKIP:${PN} += "dev-so" |