blob: 0d250e7a066073965c6f937a38c510ec121b51cf [file] [log] [blame]
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -06001SUMMARY = "FRU properties config for ipmi-fru-parser"
2PR = "r1"
3
4inherit native
5inherit obmc-phosphor-license
6inherit phosphor-ipmi-fru
7
8SRC_URI += "file://config.yaml"
9
10DEPENDS += " \
11 mrw-native \
12 mrw-perl-tools-native \
13 "
14
15PROVIDES += "virtual/phosphor-ipmi-fru-properties"
16
17S = "${WORKDIR}"
18
19do_install() {
20 DEST=${D}${properties_datadir}
21 install -d ${DEST}
22
23 ${bindir}/perl-native/perl \
24 ${bindir}/gen_fru_properties.pl \
25 -m ${datadir}/obmc-mrw/${MACHINE}.xml \
26 -c config.yaml \
Ratan Gupta338899a2017-03-30 14:32:02 +053027 -o ${DEST}/extra-properties.yaml
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -060028}