blob: 7bd2d9d7475ec7313d1a676150f6f1202182da68 [file] [log] [blame]
Brad Bishop93fb5352015-09-09 03:59:20 +00001# Common code for Phosphor OpenBMC systemd services.
2
3inherit systemd
4
5SYSTEMD_SERVICE_${PN} = "${PN}.service"
6SRC_URI += " \
7 file://${PN}.service \
8 "
9
10do_install_append() {
11 # install systemd unit files
12 install -d ${D}${systemd_unitdir}/system
13 install -m 0644 ${WORKDIR}/${PN}.service ${D}${systemd_unitdir}/system
14}