blob: c61913d056dc826c03bfd3114cdddb82e0db51a0 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001LICENSE = "GPLv2"
2LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
3 file://tests/COPYING;md5=d32239bcb673463ab874e80d47fae504 \
4 file://glob/COPYING.LIB;md5=4a770b67e6be0f60da244beb2de0fce4"
5require remake.inc
6
7SRC_URI += "file://version-remake.texi.patch \
8 "
9SRCREV = "cf54641d50a0165bb17622b3e9770f426ccbc561"
10S = "${WORKDIR}/git"
11
12DEPENDS += "readline guile"
13# Need to add "gettext-native" dependency to remake-native.
14# By default only "gettext-minimal-native" is added
15# when inherit gettext.
16DEPENDS_class-native += "gettext-native"
17PROVIDES += "make"
18
19do_configure_prepend() {
20 # remove the default LINGUAS since we are not going to generate languages
21 rm ${S}/po/LINGUAS
22 touch ${S}/po/LINGUAS
23 # create config.rpath which required by configure.ac
24 ( cd ${S}; autopoint || touch config.rpath )
25}
26
27BBCLASSEXTEND = "native"