blob: 33ffc8803a0220e80586d54e809357c6f7eda4d8 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# This file was derived from the 'Hello World!' example recipe in the
3# Yocto Project Development Manual.
4#
5
6DESCRIPTION = "Simple helloworld application used to test the devtool upgrade feature"
7SECTION = "devtool"
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
10PR = "r0"
11
12SRC_URI = "file://${THISDIR}/files/${P}.tar.gz \
13 file://0001-helloword.c-exit-with-EXIT_SUCCESS-instead-of-a-magi.patch \
14 "
15
16S = "${WORKDIR}/${P}"
17
18do_compile() {
19 ${CC} helloworld.c -o helloworld
20}
21
22do_install() {
23 install -d ${D}${bindir}
24 install -m 0755 helloworld ${D}${bindir}
25}