blob: 9bbff208c46f7df4f86837d82f2c61068ba2d59e [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Generic font configuration library"
2DESCRIPTION = "Fontconfig is a font configuration and customization library, which \
3does not depend on the X Window System. It is designed to locate \
4fonts within the system and select them according to requirements \
5specified by applications. \
6Fontconfig is not a rasterization library, nor does it impose a \
7particular rasterization library on the application. The X-specific \
8library 'Xft' uses fontconfig along with freetype to specify and \
9rasterize fonts."
10
11HOMEPAGE = "http://www.fontconfig.org"
12BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=fontconfig"
13
14LICENSE = "MIT-style & MIT & PD"
15LIC_FILES_CHKSUM = "file://COPYING;md5=7a0449e9bc5370402a94c00204beca3d \
16 file://src/fcfreetype.c;endline=45;md5=5d9513e3196a1fbfdfa94051c09dfc84 \
17 file://src/fccache.c;beginline=1199;endline=1214;md5=0326cfeb4a7333dd4dd25fbbc4b9f27f"
18
19SECTION = "libs"
20
21DEPENDS = "expat freetype zlib"
22
23SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \
24 file://revert-static-pkgconfig.patch \
25 "
26SRC_URI[md5sum] = "479be870c7f83f15f87bac085b61d641"
27SRC_URI[sha256sum] = "73f6d323c7bcfbde25d78397675191d55b8f4139132c6a9444410f3a2d8a9a95"
28
29PACKAGES =+ "fontconfig-utils"
30FILES_${PN} =+ "${datadir}/xml/*"
31FILES_fontconfig-utils = "${bindir}/*"
32
33# Work around past breakage in debian.bbclass
34RPROVIDES_fontconfig-utils = "libfontconfig-utils"
35RREPLACES_fontconfig-utils = "libfontconfig-utils"
36RCONFLICTS_fontconfig-utils = "libfontconfig-utils"
37DEBIAN_NOAUTONAME_fontconfig-utils = "1"
38
39inherit autotools pkgconfig
40
41FONTCONFIG_CACHE_DIR ?= "${localstatedir}/cache/fontconfig"
42
43EXTRA_OECONF = " --disable-docs --with-default-fonts=${datadir}/fonts --with-cache-dir=${FONTCONFIG_CACHE_DIR}"
44
45BBCLASSEXTEND = "native"