blob: ac5a2498254a317110a0f26785c2e021f19b7bec [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Library to handle input devices in Wayland compositors"
2HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libinput/"
3SECTION = "libs"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;md5=2184aef38ff137ed33ce9a63b9d1eb8f"
7
8DEPENDS = "libevdev udev mtdev"
9
10SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BP}.tar.xz \
11 file://libinput-configure.ac-add-arg-with-libunwind.patch \
12 file://touchpad-serial-synaptics-need-to-fake-new-touches-on-TRIPLETAP.patch \
13"
14SRC_URI[md5sum] = "f91d8f4ced986f1ae16d52ea02bc7837"
15SRC_URI[sha256sum] = "7cce7a9e510dfe5c4a19ad00e9350808d4f59f8611fd2b5e87213c507283f550"
16
17inherit autotools pkgconfig
18
19PACKAGECONFIG ??= ""
20PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
21PACKAGECONFIG[gui] = "--enable-event-gui,--disable-event-gui,cairo gtk+3"
22
23FILES_${PN} += "${libdir}/udev/"
24FILES_${PN}-dbg += "${libdir}/udev/.debug"