blob: 5ba07e9ab9a8bbb02f5a9dca867754b800c05975 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Power usage tool"
2DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management."
3HOMEPAGE = "http://01.org/powertop/"
4BUGTRACKER = "http://bugzilla.lesswatts.org/"
5DEPENDS = "ncurses libnl pciutils"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
8
9SRC_URI = "http://01.org/sites/default/files/downloads/powertop/powertop-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "e0d686e47daaf7e9d89031f7763432ef"
12SRC_URI[sha256sum] = "8d4b1490e2baad4467c0ded3c423db4472dcbf7b2dd8f8f2a928f54047c678ca"
13
14inherit autotools gettext pkgconfig
15
16# we need to explicitly link with libintl in uClibc systems
17EXTRA_LDFLAGS ?= ""
18EXTRA_LDFLAGS_libc-uclibc = "-lintl"
19LDFLAGS += "${EXTRA_LDFLAGS}"
20
21# we do not want libncursesw if we can
22do_configure_prepend() {
23 # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one
24 sed -i -e "s/ncursesw//g" ${S}/configure.ac
25 mkdir -p ${B}/src/tuning/
26}
27
28inherit update-alternatives
29ALTERNATIVE_${PN} = "powertop"
30ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop"
31ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop"
32ALTERNATIVE_PRIORITY = "100"