blob: eb5fa1ffe663e68efc4c514e1e93672e92cf2769 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Qt for Embedded Linux (Qt without X11)"
2PR = "r2"
3LICENSE = "MIT"
4
5# Qt4 could NOT be built on MIPS64 with 64 bits userspace
6COMPATIBLE_HOST_mips64 = "null"
7
8inherit packagegroup
9
10TOUCH = ' ${@bb.utils.contains("MACHINE_FEATURES", "touchscreen", "tslib tslib-calibrate tslib-tests", "",d)}'
11
12RDEPENDS_${PN} = " \
13 qt4-embedded \
14 libqt-embedded3support4 \
15 libqt-embeddedclucene4 \
16 libqt-embeddedcore4 \
17 libqt-embeddeddbus4 \
18 libqt-embeddedgui4 \
19 libqt-embeddedhelp4 \
20 libqt-embeddedmultimedia4 \
21 libqt-embeddednetwork4 \
22 libqt-embeddedscript4 \
23 libqt-embeddedscripttools4 \
24 libqt-embeddedsql4 \
25 libqt-embeddedsvg4 \
26 libqt-embeddedtest4 \
27 libqt-embeddedwebkit4 \
28 libqt-embeddedxml4 \
29 qt4-embedded-fonts-ttf-dejavu \
30 qt4-embedded-fonts-ttf-vera \
31 qt4-embedded-plugin-iconengine-svgicon \
32 qt4-embedded-plugin-imageformat-gif \
33 qt4-embedded-plugin-imageformat-ico \
34 qt4-embedded-plugin-imageformat-jpeg \
35 qt4-embedded-plugin-imageformat-mng \
36 qt4-embedded-plugin-imageformat-svg \
37 qt4-embedded-plugin-imageformat-tiff \
38 qt4-embedded-plugin-mousedriver-tslib \
39 qt4-embedded-plugin-script-dbus \
40 qt4-embedded-plugin-sqldriver-sqlite \
41 ${TOUCH} \
42 qt4-embedded-demos \
43 qt4-embedded-examples \
44 qt-demo-init \
45 qt4-embedded-assistant \
46"
47
48RRECOMMENDS_${PN} = " \
49 libqt-embeddedxmlpatterns4 \
50 qt4-embedded-plugin-phonon-backend-gstreamer \
51"
52