blob: bc1b0a4d46062cdc9f006471a8af546109b83958 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "A simple shell script to run all installed ptests"
2DESCRIPTION = "The ptest-runner package installs a ptest-runner \
3shell script which loops through all installed ptest test suites and \
4runs them in sequence."
5HOMEPAGE = "https://wiki.yoctoproject.org/wiki/Ptest"
6SRC_URI += "file://ptest-runner"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
10 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
11
12INHIBIT_DEFAULT_DEPS = "1"
13
14S = "${WORKDIR}"
15
16do_install () {
17 mkdir -p ${D}${bindir}
18 install -m 0755 ${WORKDIR}/ptest-runner ${D}${bindir}
19}
20
21do_patch[noexec] = "1"
22do_configure[noexec] = "1"
23do_compile[noexec] = "1"
24do_build[noexec] = "1"