blob: 858d5fcaa0f1c92f7a95805c0ecc26b6915eca73 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# yocto-bsp-filename {{ if kernel_choice == "linux-yocto_3.14": }} this
2FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
3
4PR := "${PR}.1"
5
6COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"
7
8{{ input type:"boolean" name:"need_new_kbranch" prio:"20" msg:"Do you need a new machine branch for this BSP (the alternative is to re-use an existing branch)? [y/n]" default:"y" }}
9
10{{ if need_new_kbranch == "y": }}
11{{ input type:"choicelist" name:"new_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/edgerouter" }}
12
13{{ if need_new_kbranch == "n": }}
14{{ input type:"choicelist" name:"existing_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/edgerouter" }}
15
16{{ if need_new_kbranch == "n": }}
17KBRANCH_{{=machine}} = "{{=existing_kbranch}}"
18
19{{ input type:"boolean" name:"smp" prio:"30" msg:"Do you need SMP support? (y/n)" default:"y"}}
20{{ if smp == "y": }}
21KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc"
22
23SRC_URI += "file://{{=machine}}-standard.scc \
24 file://{{=machine}}-user-config.cfg \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050025 file://{{=machine}}-user-features.scc \
26 "
27
Patrick Williamsf1e5d692016-03-30 15:21:19 -050028# replace these SRCREVs with the real commit ids once you've had
Patrick Williamsc124f4f2015-09-15 14:41:29 -050029# the appropriate changes committed to the upstream linux-yocto repo
30SRCREV_machine_pn-linux-yocto_{{=machine}} ?= "dbe5b52e93ff114b2c0f5da6f6af91f52c18f2b8"
31SRCREV_meta_pn-linux-yocto_{{=machine}} ?= "6eddbf47875ef48ddc5864957a7b63363100782b"
Patrick Williamsf1e5d692016-03-30 15:21:19 -050032#LINUX_VERSION = "3.14"