blob: 913342c315de97ae979ec007ca211aa59fe829a7 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Random number generator daemon"
2DESCRIPTION = "Check and feed random data from hardware device to kernel"
3AUTHOR = "Philipp Rumpf, Jeff Garzik <jgarzik@pobox.com>, \
4 Henrique de Moraes Holschuh <hmh@debian.org>"
5HOMEPAGE = "https://github.com/nhorman/rng-tools"
6BUGTRACKER = "https://github.com/nhorman/rng-tools/issues"
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
9DEPENDS = "sysfsutils"
10
11SRC_URI = "\
12 git://github.com/nhorman/rng-tools.git \
13 file://init \
14 file://default \
15 file://rngd.service \
16"
17SRCREV = "4a865797a69dd38c64a86aa32884ecc9ba7b4d08"
18
19S = "${WORKDIR}/git"
20
21inherit autotools update-rc.d systemd pkgconfig
22
23PACKAGECONFIG ??= "libgcrypt libjitterentropy"
24PACKAGECONFIG_libc-musl = "libargp libjitterentropy"
25
26PACKAGECONFIG[libargp] = "--with-libargp,--without-libargp,argp-standalone,"
27PACKAGECONFIG[libgcrypt] = "--with-libgcrypt,--without-libgcrypt,libgcrypt,"
28PACKAGECONFIG[libjitterentropy] = "--enable-jitterentropy,--disable-jitterentropy,libjitterentropy"
29PACKAGECONFIG[libp11] = "--with-pkcs11,--without-pkcs11,libp11 openssl"
30PACKAGECONFIG[nistbeacon] = "--with-nistbeacon,--without-nistbeacon,curl libxml2 openssl"
31
32INITSCRIPT_NAME = "rng-tools"
33INITSCRIPT_PARAMS = "start 03 2 3 4 5 . stop 30 0 6 1 ."
34
35SYSTEMD_SERVICE_${PN} = "rngd.service"
36
37# Refer autogen.sh in rng-tools
38do_configure_prepend() {
39 cp ${S}/README.md ${S}/README
40}
41
42do_install_append() {
43 install -Dm 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/rng-tools
44 install -Dm 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/rng-tools
45 install -Dm 0644 ${WORKDIR}/rngd.service \
46 ${D}${systemd_system_unitdir}/rngd.service
47 sed -i \
48 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
49 -e 's,@SBINDIR@,${sbindir},g' \
50 ${D}${sysconfdir}/init.d/rng-tools \
51 ${D}${systemd_system_unitdir}/rngd.service
Andrew Geissler82c905d2020-04-13 13:39:40 -050052}