Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "GNU Transport Layer Security Library" |
| 2 | DESCRIPTION = "a secure communications library implementing the SSL, \ |
| 3 | TLS and DTLS protocols and technologies around them." |
| 4 | HOMEPAGE = "https://gnutls.org/" |
| 5 | BUGTRACKER = "https://savannah.gnu.org/support/?group=gnutls" |
| 6 | |
| 7 | LICENSE = "GPL-3.0-or-later & LGPL-2.1-or-later" |
| 8 | LICENSE:${PN} = "LGPL-2.1-or-later" |
| 9 | LICENSE:${PN}-xx = "LGPL-2.1-or-later" |
| 10 | LICENSE:${PN}-bin = "GPL-3.0-or-later" |
| 11 | LICENSE:${PN}-OpenSSL = "GPL-3.0-or-later" |
| 12 | |
| 13 | LIC_FILES_CHKSUM = "file://LICENSE;md5=71391c8e0c1cfe68077e7fce3b586283 \ |
| 14 | file://doc/COPYING;md5=c678957b0c8e964aa6c70fd77641a71e \ |
| 15 | file://doc/COPYING.LESSER;md5=a6f89e2100d9b6cdffcea4f398e37343" |
| 16 | |
| 17 | DEPENDS = "nettle gmp virtual/libiconv libunistring" |
| 18 | DEPENDS:append:libc-musl = " argp-standalone" |
| 19 | |
| 20 | SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}" |
| 21 | |
| 22 | SRC_URI = "https://www.gnupg.org/ftp/gcrypt/gnutls/v${SHRT_VER}/gnutls-${PV}.tar.xz \ |
| 23 | file://arm_eabi.patch \ |
| 24 | " |
| 25 | |
| 26 | SRC_URI[sha256sum] = "e6adbebcfbc95867de01060d93c789938cf89cc1d1f6ef9ef661890f6217451f" |
| 27 | |
| 28 | inherit autotools texinfo pkgconfig gettext lib_package gtk-doc |
| 29 | |
| 30 | PACKAGECONFIG ??= "libidn ${@bb.utils.filter('DISTRO_FEATURES', 'seccomp', d)}" |
| 31 | |
| 32 | # You must also have CONFIG_SECCOMP enabled in the kernel for |
| 33 | # seccomp to work. |
| 34 | PACKAGECONFIG[seccomp] = "--with-libseccomp-prefix=${STAGING_EXECPREFIXDIR},ac_cv_libseccomp=no,libseccomp" |
| 35 | PACKAGECONFIG[libidn] = "--with-idn,--without-idn,libidn2" |
| 36 | PACKAGECONFIG[libtasn1] = "--with-included-libtasn1=no,--with-included-libtasn1,libtasn1" |
| 37 | PACKAGECONFIG[p11-kit] = "--with-p11-kit,--without-p11-kit,p11-kit" |
| 38 | PACKAGECONFIG[tpm] = "--with-tpm,--without-tpm,trousers" |
| 39 | |
| 40 | EXTRA_OECONF = " \ |
| 41 | --enable-doc \ |
| 42 | --disable-libdane \ |
| 43 | --disable-guile \ |
| 44 | --disable-rpath \ |
| 45 | --enable-openssl-compatibility \ |
| 46 | --with-libpthread-prefix=${STAGING_DIR_HOST}${prefix} \ |
| 47 | --with-librt-prefix=${STAGING_DIR_HOST}${prefix} \ |
| 48 | --with-default-trust-store-file=${sysconfdir}/ssl/certs/ca-certificates.crt \ |
| 49 | " |
| 50 | |
| 51 | # Otherwise the tools try and use HOSTTOOLS_DIR/bash as a shell. |
| 52 | export POSIX_SHELL="${base_bindir}/sh" |
| 53 | |
| 54 | LDFLAGS:append:libc-musl = " -largp" |
| 55 | |
| 56 | do_configure:prepend() { |
| 57 | for dir in . lib; do |
| 58 | rm -f ${dir}/aclocal.m4 ${dir}/m4/libtool.m4 ${dir}/m4/lt*.m4 |
| 59 | done |
| 60 | } |
| 61 | |
| 62 | PACKAGES =+ "${PN}-openssl ${PN}-xx" |
| 63 | |
| 64 | FILES:${PN}-dev += "${bindir}/gnutls-cli-debug" |
| 65 | FILES:${PN}-openssl = "${libdir}/libgnutls-openssl.so.*" |
| 66 | FILES:${PN}-xx = "${libdir}/libgnutlsxx.so.*" |
| 67 | |
| 68 | BBCLASSEXTEND = "native nativesdk" |