Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Baremetal examples to work with the several QEMU architectures supported on OpenEmbedded" |
| 2 | HOMEPAGE = "https://github.com/aehs29/baremetal-helloqemu" |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 3 | DESCRIPTION = "These are introductory examples to showcase the use of QEMU to run baremetal applications." |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=39346640a23c701e4f459e05f56f4449" |
| 6 | |
Patrick Williams | 0ca19cc | 2021-08-16 14:03:13 -0500 | [diff] [blame] | 7 | SRCREV = "31b4e5a337018b4a00a7426b0e5ed83b81df30c7" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 8 | PV = "0.1+git${SRCPV}" |
| 9 | |
| 10 | SRC_URI = "git://github.com/aehs29/baremetal-helloqemu.git;protocol=https;branch=master" |
| 11 | |
Andrew Geissler | f034379 | 2020-11-18 10:42:21 -0600 | [diff] [blame] | 12 | S = "${WORKDIR}/git" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 14 | # The following variables should be set to accomodate each application |
| 15 | BAREMETAL_BINNAME ?= "hello_baremetal_${MACHINE}" |
| 16 | IMAGE_LINK_NAME ?= "baremetal-helloworld-image-${MACHINE}" |
| 17 | IMAGE_NAME_SUFFIX ?= "" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 19 | # Baremetal-Image creates the proper wiring, assumes the output is provided in |
| 20 | # binary and ELF format, installed on ${base_libdir}/firmware/ , we want a |
| 21 | # package to be created since we might have some way of updating the baremetal |
| 22 | # firmware from Linux |
| 23 | inherit baremetal-image |
| 24 | |
| 25 | |
| 26 | # These parameters are app specific for this example |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 27 | # This will be translated automatically to the architecture and |
| 28 | # machine that QEMU uses on OE, e.g. -machine virt -cpu cortex-a57 |
| 29 | # but the examples can also be run on other architectures/machines |
| 30 | # such as vexpress-a15 by overriding the setting on the machine.conf |
Patrick Williams | 0ca19cc | 2021-08-16 14:03:13 -0500 | [diff] [blame] | 31 | COMPATIBLE_MACHINE = "qemuarmv5|qemuarm|qemuarm64|qemuriscv64|qemuriscv32" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 32 | |
| 33 | BAREMETAL_QEMUARCH ?= "" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | BAREMETAL_QEMUARCH:qemuarmv5 = "versatile" |
| 35 | BAREMETAL_QEMUARCH:qemuarm = "arm" |
| 36 | BAREMETAL_QEMUARCH:qemuarm64 = "aarch64" |
| 37 | BAREMETAL_QEMUARCH:qemuriscv64 = "riscv64" |
Patrick Williams | 0ca19cc | 2021-08-16 14:03:13 -0500 | [diff] [blame] | 38 | BAREMETAL_QEMUARCH:qemuriscv32 = "riscv32" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 39 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 40 | EXTRA_OEMAKE:append = " QEMUARCH=${BAREMETAL_QEMUARCH} V=1" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 41 | |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 42 | |
| 43 | # Install binaries on the proper location for baremetal-image to fetch and deploy |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 44 | do_install(){ |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 45 | install -d ${D}/${base_libdir}/firmware |
Andrew Geissler | 4c19ea1 | 2020-10-27 13:52:24 -0500 | [diff] [blame] | 46 | install -m 755 ${B}/build/hello_baremetal_${BAREMETAL_QEMUARCH}.bin ${D}/${base_libdir}/firmware/${BAREMETAL_BINNAME}.bin |
| 47 | install -m 755 ${B}/build/hello_baremetal_${BAREMETAL_QEMUARCH}.elf ${D}/${base_libdir}/firmware/${BAREMETAL_BINNAME}.elf |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 48 | } |
| 49 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 50 | FILES:${PN} += " \ |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 51 | ${base_libdir}/firmware/${BAREMETAL_BINNAME}.bin \ |
| 52 | ${base_libdir}/firmware/${BAREMETAL_BINNAME}.elf \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 53 | " |