blob: 512619098af9d7b0eb567cd1af7311c1c8779846 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "wolfSSL Lightweight, Embedded SSL Library"
2DESCRIPTION = "wolfSSL, formerly CyaSSL, is a lightweight SSL library written in C and \
3 optimized for embedded and RTOS environments. It can be \
4 Up to 20 times smaller than OpenSSL while still supporting \
5 a full TLS 1.2 client and server."
6HOMEPAGE = "http://www.wolfssl.com/yaSSL/Products-wolfssl.html"
7BUGTRACKER = "http://github.com/wolfssl/wolfssl/issues"
8SECTION = "libs"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12PROVIDES += "cyassl"
13RPROVIDES_${PN} = "cyassl"
14
15SRC_URI = "https://github.com/wolfSSL/wolfssl/archive/v${PV}-stable.zip \
16 file://0001-fix-no-rule-to-make-cyassl-options.h.patch \
17 "
18
19SRC_URI[md5sum] = "f9caf558169ab650dc8200708799ebeb"
20SRC_URI[sha256sum] = "b6d87d3e2c8757177d69aff373c91cf162f4a3944fae90fa10d086fd5f9542e7"
21
22S = "${WORKDIR}/wolfssl-${PV}-stable"
23
24inherit autotools
25
26PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
27PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"