blob: 4d1b0c4370abba8589c58f4b96e730cab13276ff [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Network benchmark tool"
2DESCRIPTION = "\
3iperf is a tool for active measurements of the maximum achievable bandwidth \
4on IP networks. It supports tuning of various parameters related to timing, \
5protocols, and buffers. For each test it reports the bandwidth, loss, and \
6other parameters."
7HOMEPAGE = "http://software.es.net/iperf/"
8SECTION = "console/network"
9BUGTRACKER = "https://github.com/esnet/iperf/issues"
10AUTHOR = "ESNET <info@es.net>, Lawrence Berkeley National Laboratory <websupport@lbl.gov>"
11LICENSE = "BSD"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=d098223e44bdd19585315ee75cd9d2d7"
13
14DEPENDS = "openssl"
15
16SRC_URI = "git://github.com/esnet/iperf.git \
17 file://automake-foreign.patch \
18 file://0001-include-stdint.h-for-various-std-c99-int-types.patch \
19 file://0002-Remove-pg-from-profile_CFLAGS.patch \
20 "
21
22SRCREV = "88d907f7fb58bfab5d086c5da60c922e1c582c92"
23
24S = "${WORKDIR}/git"
25
26inherit autotools
27
28PACKAGECONFIG[lksctp] = "ac_cv_header_netinet_sctp_h=yes,ac_cv_header_netinet_sctp_h=no,lksctp-tools"
29
30CFLAGS += "-D_GNU_SOURCE"
31
32EXTRA_OECONF = "--with-openssl=${RECIPE_SYSROOT}"
33
34BBCLASSEXTEND = "native"