blob: 489861cb7bc096e65ad67c34af7318d6ae1b232c [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "A tool for transfer files to/from any OBEX enabled device"
2LICENSE = "GPLv2 & PD & LGPLv2.1"
3LIC_FILES_CHKSUM = "file://LGPL-2.1.txt;md5=4fbd65380cdd255951079008b364516c \
4 file://GPL-2.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
5 file://License.txt;md5=fcbddc3c1debed80dd80da2d3e5f0dc1 \
6 "
7
8DEPENDS += "openobex obexftp-native"
9SRC_URI = "http://downloads.sourceforge.net/openobex/${BP}-Source.tar.gz \
10 file://Remove_some_printf_in_obexftpd.patch \
11 file://0001-apps-CMakeLists.txt-Explicitly-link-libbfb-and-libmu.patch \
12 file://make_fuse_swig_optional.patch \
13"
14SRC_URI[md5sum] = "157a9d1b2ed220203f7084db906de73c"
15SRC_URI[sha256sum] = "d40fb48e0a0eea997b3e582774b29f793919a625d54b87182e31a3f3d1c989a3"
16
17inherit cmake pkgconfig
18
19PACKAGECONFIG ?= ""
20# fuse support will need meta-filesystems layer
21PACKAGECONFIG[fuse] = "-DENABLE_FUSE=ON,-DENABLE_FUSE=OFF,fuse"
22PACKAGECONFIG[swig] = "-DENABLE_SWIG=ON,-DENABLE_SWIG=OFF,swig"
23
24DEPENDS_remove_class-native = "fuse-native"
25
26S = "${WORKDIR}/${BP}-Source"
27
28EXTRA_OECMAKE += "-DCMAKE_SKIP_RPATH=ON \
29 -DENABLE_PERL=OFF -DENABLE_PYTHON=OFF \
30 -DENABLE_RUBY=OFF -DENABLE_TCL=OFF \
31"
32
33do_compile_class-native () {
34 oe_runmake crctable
35}
36
37do_install_class-native () {
38 install -D -m 0755 ${B}/bfb/crctable ${D}${bindir}/crctable
39}
40
41BBCLASSEXTEND = "native"