blob: fae7c18a168f115722a0c34a59b237b89fae92bb [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Protocol Buffers - structured data serialisation mechanism"
2DESCRIPTION = "Protocol Buffers are a way of encoding structured data in an \
3efficient yet extensible format. Google uses Protocol Buffers for almost \
4all of its internal RPC protocols and file formats."
5HOMEPAGE = "https://github.com/google/protobuf"
6SECTION = "console/tools"
7LICENSE = "BSD-3-Clause"
8
9PACKAGE_BEFORE_PN = "${PN}-compiler ${PN}-lite"
10
11DEPENDS = "zlib"
12RDEPENDS_${PN}-compiler = "${PN}"
13RDEPENDS_${PN}-dev += "${PN}-compiler"
14
15LIC_FILES_CHKSUM = "file://LICENSE;md5=35953c752efc9299b184f91bef540095"
16
17SRCREV = "b04e5cba356212e4e8c66c61bbe0c3a20537c5b9"
18
19PV = "3.4.1+git${SRCPV}"
20
21SRC_URI = "git://github.com/google/protobuf.git;branch=3.4.x"
22
23EXTRA_OECONF += " --with-protoc=echo"
24
25inherit autotools-brokensep
26
27S = "${WORKDIR}/git"
28
29FILES_${PN}-compiler = "${bindir} ${libdir}/libprotoc${SOLIBS}"
30FILES_${PN}-lite = "${bindir} ${libdir}/libprotobuf-lite${SOLIBS}"
31
32MIPS_INSTRUCTION_SET = "mips"
33
34BBCLASSEXTEND = "native nativesdk"