blob: 9d2e1655482bfdc806cc05c593069ddba01b19f0 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Python GObject bindings"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05002HOMEPAGE = "http://www.pygtk.org/"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05003SECTION = "devel/python"
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
6
7inherit autotools pkgconfig gnomebase distutils-base gobject-introspection
8
9PYTHON_BASEVERSION = "2.7"
10PYTHON_PN = "python"
11
12DEPENDS += "gnome-common-native python glib-2.0"
13
14SRCNAME="pygobject"
15SRC_URI = " \
16 http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \
17 file://0001-configure.ac-add-sysroot-path-to-GI_DATADIR-don-t-se.patch \
18"
19
20SRC_URI[md5sum] = "ed4117ed5d554d25fd7718807fbf819f"
21SRC_URI[sha256sum] = "08b29cfb08efc80f7a8630a2734dec65a99c1b59f1e5771c671d2e4ed8a5cbe7"
22
23S = "${WORKDIR}/${SRCNAME}-${PV}"
24
25BBCLASSEXTEND = "native"
26
27EXTRA_OECONF = "--disable-cairo --with-python=${PYTHON}"
28
29RDEPENDS_${PN} += "python-setuptools python-importlib"
30RDEPENDS_${PN}_class-native = ""
31
32do_install_append() {
33 # Remove files that clash with python3-pygobject; their content is same
34 rm -rf ${D}${includedir}/pygobject-3.0//pygobject.h ${D}${libdir}/pkgconfig
35}