blob: 574f6601ca99026f66231f57a1ca116d55eb3303 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "An IPC library for high performance servers"
2DESCRIPTION = "libqb is a library with the primary purpose of providing high performance client server reusable features. \
3It provides high performance logging, tracing, ipc, and poll."
4
5HOMEPAGE = "https://github.com/clusterlabs/libqb/wiki"
6SECTION = "libs"
7LICENSE = "LGPL-2.1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=321bf41f280cf805086dd5a720b37785"
9
10inherit autotools pkgconfig
11
12PV .= "+git${SRCPV}"
13
14SRCREV = "608de6d59a3de0eef0fbcbd8f284acbc018daa9a"
15SRC_URI = "git://github.com/ClusterLabs/${BPN}.git \
16 file://0001-Remove-runtime-check-for-CLOCK_MONOTONIC.patch \
17 "
18S = "${WORKDIR}/git"
19
20do_configure_prepend() {
21 ( cd ${S}
22 ${S}/autogen.sh )
23}