blob: 81e8e96249a6b83b14b64914fee21eefadbd157b [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001# This recipe is modified from the recipe originally found in the Open-Switch
2# repository:
3#
4# https://github.com/open-switch/ops-build
5# yocto/openswitch/meta-foss-openswitch/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.0.5.bb
6# Commit 9008de2d8e100f3f868c66765742bca9fa98f3f9
7#
8# The recipe packaging has been relicensed under the MIT license for inclusion
9# in meta-openembedded by agreement of the author (Diego Dompe).
10#
11
12SUMMARY = "Tools to enhance VMWare guest integration and performance"
13HOMEPAGE = "https://github.com/vmware/open-vm-tools"
14SECTION = "vmware-tools"
15
16LICENSE = "LGPL-2.0 & GPL-2.0 & BSD & CDDL-1.0"
17LIC_FILES_CHKSUM = "file://LICENSE;md5=b66ba4cb4fc017682c95efc300410e79"
18LICENSE_modules/freebsd/vmblock = "BSD"
19LICENSE_modules/freebsd/vmmemctl = "GPL-2.0"
20LICENSE_modules/freebsd/vmxnet = "GPL-2.0"
21LICENSE_modules/linux = "GPL-2.0"
22LICENSE_modules/solaris = "CDDL-1.0"
23
24SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https \
25 file://tools.conf \
26 file://vmtoolsd.service \
27 file://0001-configure.ac-don-t-use-dnet-config.patch \
28 file://0002-add-include-sys-sysmacros.h.patch \
29 file://0001-Remove-assumptions-about-glibc-being-only-libc-imple.patch \
30 file://0002-include-poll.h-instead-of-obsolete-sys-poll.h.patch \
31 file://0003-Rename-poll.h-to-vm_poll.h.patch \
32 file://0004-Add-Wno-incompatible-pointer-types-and-Wno-error-add.patch \
33 file://0005-Use-configure-test-for-struct-timespec.patch \
34 file://0006-Fix-definition-of-ALLPERMS-and-ACCESSPERMS.patch \
35 file://0007-Use-configure-to-test-for-feature-instead-of-platfor.patch \
36 file://0008-use-posix-strerror_r-unless-gnu.patch \
37 file://0011-Use-configure-test-for-sys-stat.h-include.patch \
38 "
39SRC_URI_append_libc-musl = "\
40 file://0009-Add-support-for-building-with-system-libtirpc.patch \
41 file://0010-gnu-ucontext.patch \
42 "
43SRCREV = "854c0bb374612f7e633b448ca273f970f154458b"
44
45S = "${WORKDIR}/git/open-vm-tools"
46
47DEPENDS = "glib-2.0 glib-2.0-native util-linux libdnet procps"
48DEPENDS_append_libc-musl = " libtirpc"
49
50# open-vm-tools is supported only on x86.
51COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
52
53inherit autotools pkgconfig systemd
54
55SYSTEMD_SERVICE_${PN} = "vmtoolsd.service"
56
57EXTRA_OECONF = "--without-icu --disable-multimon --disable-docs \
58 --disable-tests --without-gtkmm --without-xerces --without-pam \
59 --disable-grabbitmqproxy --disable-vgauth --disable-deploypkg \
60 --without-root-privileges --without-kernel-modules"
61
62NO_X11_FLAGS = "--without-x --without-gtk2 --without-gtk3"
63X11_DEPENDS = "libxext libxi libxrender libxrandr libxtst gtk+ gdk-pixbuf"
64PACKAGECONFIG[x11] = ",${NO_X11_FLAGS},${X11_DEPENDS}"
65
66# fuse gets implicitly detected; there is no --without-fuse option.
67PACKAGECONFIG[fuse] = ",,fuse"
68
69CFLAGS_append_toolchain-clang = " -Wno-address-of-packed-member"
70FILES_${PN} += "\
71 ${libdir}/open-vm-tools/plugins/vmsvc/lib*.so \
72 ${libdir}/open-vm-tools/plugins/common/lib*.so \
73 ${sysconfdir}/vmware-tools/tools.conf \
74 "
75FILES_${PN}-locale += "${datadir}/open-vm-tools/messages"
76FILES_${PN}-dev += "${libdir}/open-vm-tools/plugins/common/lib*.la"
77FILES_${PN}-dbg += "\
78 ${libdir}/open-vm-tools/plugins/common/.debug \
79 ${libdir}/open-vm-tools/plugins/vmsvc/.debug \
80 "
81
82CONFFILES_${PN} += "${sysconfdir}/vmware-tools/tools.conf"
83
84RDEPENDS_${PN} = "util-linux libdnet fuse"
85
86do_install_append() {
87 ln -sf ${sbindir}/mount.vmhgfs ${D}/sbin/mount.vmhgfs
88 install -d ${D}${systemd_unitdir}/system ${D}${sysconfdir}/vmware-tools
89 install -m 644 ${WORKDIR}/*.service ${D}${systemd_unitdir}/system
90 install -m 0644 ${WORKDIR}/tools.conf ${D}${sysconfdir}/vmware-tools/tools.conf
91}
92
93do_configure_prepend() {
94 export CUSTOM_DNET_NAME=dnet
95 export CUSTOM_DNET_LIBS=-L${STAGING_LIBDIR}/libdnet.so
96}
97
98python() {
99 if 'networking-layer' not in d.getVar('BBFILE_COLLECTIONS').split() or \
100 'filesystems-layer' not in d.getVar('BBFILE_COLLECTIONS').split():
101 raise bb.parse.SkipRecipe('Requires meta-networking and meta-filesystems to be present.')
102}
103