blob: 4e893dbba13d6509d6373ee3e6aad1f2dab49070 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "The Apache HTTP Server is a powerful, efficient, and \
2extensible web server."
3SUMMARY = "Apache HTTP Server"
4HOMEPAGE = "http://httpd.apache.org/"
5DEPENDS = "expat-native pcre-native apr-native apr-util-native"
6SECTION = "net"
7LICENSE = "Apache-2.0"
8
9inherit autotools pkgconfig native
10
11SRC_URI = "${APACHE_MIRROR}/httpd/httpd-${PV}.tar.bz2 \
12 file://0001-configure-use-pkg-config-for-PCRE-detection.patch \
13 "
14
15S = "${WORKDIR}/httpd-${PV}"
16
17LIC_FILES_CHKSUM = "file://LICENSE;md5=dbff5a2b542fa58854455bf1a0b94b83"
18SRC_URI[md5sum] = "97b6bbfa83c866dbe20ef317e3afd108"
19SRC_URI[sha256sum] = "71fcc128238a690515bd8174d5330a5309161ef314a326ae45c7c15ed139c13a"
20
21EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \
22 --with-apr-util=${STAGING_BINDIR_CROSS}/apu-1-config \
23 --prefix=${prefix} --datadir=${datadir}/apache2 \
24 "
25
26do_install () {
27 install -d ${D}${bindir} ${D}${libdir}
28 cp server/gen_test_char ${D}${bindir}
29 install -m 755 support/apxs ${D}${bindir}/
30 install -m 755 httpd ${D}${bindir}/
31 install -d ${D}${datadir}/apache2/build
32 cp ${S}/build/*.mk ${D}${datadir}/apache2/build
33 cp build/*.mk ${D}${datadir}/apache2/build
34 cp ${S}/build/instdso.sh ${D}${datadir}/apache2/build
35
36 install -d ${D}${includedir}/apache2
37 cp ${S}/include/* ${D}${includedir}/apache2
38 cp include/* ${D}${includedir}/apache2
39 cp ${S}/os/unix/os.h ${D}${includedir}/apache2
40 cp ${S}/os/unix/unixd.h ${D}${includedir}/apache2
41
42 cp support/envvars-std ${D}${bindir}/envvars
43 chmod 755 ${D}${bindir}/envvars
44}
45