blob: a115037266a14a7c9ca2c2b4c2ba26ee32b58706 [file] [log] [blame]
Patrick Williams8b8bc412016-08-17 15:02:23 -05001DESCRIPTION = "Closed source binary files to help boot the ARM on the BCM2835."
2LICENSE = "Proprietary"
3
4LIC_FILES_CHKSUM = "file://LICENCE.broadcom;md5=4a4d169737c0786fb9482bb6d30401d1"
5
6inherit deploy
7
8include recipes-bsp/common/firmware.inc
9
10RDEPENDS_${PN} = "rpi-config"
11
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012COMPATIBLE_MACHINE = "^rpi$"
Patrick Williams8b8bc412016-08-17 15:02:23 -050013
14S = "${RPIFW_S}/boot"
15
16PR = "r3"
17
18do_deploy() {
19 install -d ${DEPLOYDIR}/${PN}
20
21 for i in ${S}/*.elf ; do
22 cp $i ${DEPLOYDIR}/${PN}
23 done
24 for i in ${S}/*.dat ; do
25 cp $i ${DEPLOYDIR}/${PN}
26 done
27 for i in ${S}/*.bin ; do
28 cp $i ${DEPLOYDIR}/${PN}
29 done
30
31 # Add stamp in deploy directory
32 touch ${DEPLOYDIR}/${PN}/${PN}-${PV}.stamp
33}
34
35addtask deploy before do_package after do_install
36do_deploy[dirs] += "${DEPLOYDIR}/${PN}"
37
38PACKAGE_ARCH = "${MACHINE_ARCH}"
39