blob: 565b73526a91a596bd020688c69b84b9ca75d5e5 [file] [log] [blame]
Brad Bishop3a5fbf52017-12-04 02:17:07 -05001FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
Brad Bishop6e60e8b2018-02-01 10:27:11 -05003SRC_URI += " \
4 file://brcmfmac43430-sdio.bin \
5 file://brcmfmac43430-sdio.txt \
6 "
Brad Bishop3a5fbf52017-12-04 02:17:07 -05007
8do_install_append() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -05009 # Overwrite v7.45.41.26 by the one we currently provide in this layer
10 # (v7.45.41.46)
11 local _firmware="brcmfmac43430-sdio.bin"
12 local _oldmd5=9258986488eca9fe5343b0d6fe040f8e
13 if [ "$(md5sum ${D}/lib/firmware/brcm/$_firmware | awk '{print $1}')" != "$_oldmd5" ]; then
14 _firmware=""
15 bbwarn "linux-firmware stopped providing brcmfmac43430 v7.45.41.26."
16 else
17 _firmware="${WORKDIR}/$_firmware"
18 fi
19
20 mkdir -p ${D}/lib/firmware/brcm
21 install -m 0644 $_firmware ${WORKDIR}/brcmfmac43430-sdio.txt ${D}/lib/firmware/brcm
Brad Bishop3a5fbf52017-12-04 02:17:07 -050022}
23
24FILES_${PN}-bcm43430 += " \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025 /lib/firmware/brcm/brcmfmac43430-sdio.txt \
Brad Bishop3a5fbf52017-12-04 02:17:07 -050026"