blob: b947659644572c4290eed65828c735e8c3d2b861 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001python __anonymous() {
2 if "linux-raspberrypi-dev" not in d.getVar("PREFERRED_PROVIDER_virtual/kernel"):
3 msg = "Skipping linux-raspberrypi-dev as it is not the preferred " + \
4 "provider of virtual/kernel."
5 raise bb.parse.SkipRecipe(msg)
6}
7
8FILESEXTRAPATHS_prepend := "${THISDIR}/linux-raspberrypi:"
9
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010LINUX_VERSION ?= "4.13"
11LINUX_RPI_DEV_BRANCH ?= "rpi-4.13.y"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012
13SRCREV = "${AUTOREV}"
14SRC_URI = "git://github.com/raspberrypi/linux.git;protocol=git;branch=${LINUX_RPI_DEV_BRANCH} \
15 file://0001-build-arm64-Add-rules-for-.dtbo-files-for-dts-overla.patch \
16"
17require linux-raspberrypi.inc
18
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019# Disable version check so that we don't have to edit this recipe every time
20# upstream bumps the version
21KERNEL_VERSION_SANITY_SKIP = "1"